Resolved
Website is now reachable again, no postmortem or long term incident storage is planned for this incident.
Identified
Due to new configuration requirements from our hosting platform, Mintlify, unbeknownst to Comfora required new DNS configuration.
Investigating
Homepage became unreachable and returning a certificate error, this was following a recent deployment made in our codebase.